Introduction

A Brief History: Drupal is a content management system. Its goal is to help users compose and present website content such as pages, images, and other content types. Rather than forcing users to modify code, Drupal takes care of the details of how information is arranged and presented, and lets users focus on the actual content to be displayed. Most of the content on a Drupal-based site is stored in a database. Text and images are submitted by filling in forms via a web browser. When visitors view a page, Drupal gets the relevant bits of content from the database and composes all the components of the page in a template. This makes it easy to quickly add or change content, without requiring knowledge of HTML or other web technologies on the part of the person providing the content.

Depending on the configuration of the Drupal site and the defined user roles on the site, you may be allowed to contribute and edit content or administer various aspects of the site. Fortunately, Drupal is designed to make this relatively easy. Very little technical knowledge is assumed. Though details may vary with a site's configuration, the basic process involves these steps:

- Register with the site
- Log in by typing the user name and password supplied you in the registration step
- Create content such as pages and publications based on your permission level
Logging in to Drupal

- Go to http://dev-childrens-services-council.pantheonsite.io/user/login and use the username and password provided to see the Drupal site. You will then be navigated to the Drupal login screen where you will enter the unique username and password that were assigned to you.
- The easiest way to tell if you're logged-in or not is if a black ‘admin bar’ appears at the top of the page. If you do not see the admin bar, you are likely not logged-in. Note that you may expand the menu by clicking the three parallel bars at the top left-hand corner of the page (as pictured below).

Drupal Terms

**Node** – piece of content - all Drupal-based content is created as a Node, which is necessary in order to link, associate, feature, etc. different pieces of content on other content types  
**Block** – chunk of content that can be reused in various places through the site  
**Content Type** – content defined by a unique model or page type  
**Entity** – any defined group of content (nodes are entities as are taxonomy terms, users, etc.)  
**Taxonomy** – a vocabulary used to relate and segment content  
**Theme** – a collection of files that define the look and feel of the Drupal site  
**View** – a dynamic display of content

These are just a few of the most important terms. Be sure to check out the Drupal Glossary on the Taoti blog, at [http://taoti.com/drupal-glossary](http://taoti.com/drupal-glossary).
Content Type Overview

CSC Broward’s website has 15 content types that display content across the website:

- Basic Page – for static content, such as the Marjory Stoneman Douglas Highschool Response Page
- Blog – for timely posts about relevant and interesting topics
- Career – for sharing open job opportunities
- Committee Chairperson – to display the chairperson’s name and contact information
- Committee – for displaying information about the many CSC committees, committee leader, and related topics
- Council Member – for introducing members of the Council in depth
- Event – to display upcoming events, including meetings, trainings, community events and more; intended to also act as an historical archive with relevant attachments for related resources
- Goal – for outlining goals of CSC Broward
- Homepage – for obvious reasons
- Landing Page – for main navigation items, including Families, Providers, and Community Builders
- Listing Page – used to aggregate specific types of information from multiple places on the website, like events, careers, nodes tagged with another language
- Program – page not public – used to aggregate content for inclusion in the floating ‘Get Help’ button
- Resource – for documents and other items to provide an opportunity to gain SEO with PDFs, track downloads, and enable cross-linking with other content types like events
- Staff – for displaying current staff members, their roles, and contact information
- Success Story – for telling the unique stories of those affected by the great work that CSC does
Adding Content...in general

To add content through the admin toolbar, navigate to Content > Add Content. This page will list all content types available on your website. Select the content type for the page you wish to create.

Enter content into the fields, such as ‘Title’ and ‘Summary’. Required fields are indicated by a red asterisk *. 
The Body field is also referred to as the ‘What You See is What You Get’ (WYSIWYG) editor. The acronym is pronounced ‘wiz-ee-wig’. Ensure that the ‘Text Format’ is set to ‘Basic HTML’. This format is appropriate for non-admin users entering content as it strips all but basic HTML tags for added security and removes any formatting issues that could possibly arise if copying and pasting information over. Pay special attention to this when migrating any content over manually.

Images uploaded to the site, whether in a WYSIWYG or using an Image Upload field, should be .gif, .png, .jpg or .jpeg files, which is the standard for the display of images on the web. Other file formats such as .eps and .tif are not optimized for online viewing and may slow down image load times.

When entering body content, you may key-in and format text directly into the WYSIWYG editor with the available tools such as bold, italic, and link, or you may copy-and-paste from another application such as Notepad.

In URL fields, use relative links when linking to pages/content within the site. Relative links consist of everything after the domain and they only point to a file or a file path. When a user clicks a relative link, the browser takes them to that location on the current site. For that reason, you should only use relative links when linking to pages or files within your site, and you must use absolute links (the full link) if you're linking to a location on another website. When linking to external sites, use an absolute URL with http:// before the web address.

URL aliases are automatically generated by default. For non-Basic page content, this alias includes a site path based on the information architecture of the site. New nodes are not instantly searchable on the site; they may take up to 30 minutes to be indexed so that they will be returned in site search results.

WYSIWYG

Always use the WYSIWYG in filtered HTML.

Use the Styles dropdown to select another header style (h1, h2, h3). The heading structure on a page should read like an outline and not skip levels (h2, h3, h4, etc.). This is important for Search Engine Optimization and for site 508 compliance/accessibility (screen readers, etc.) best practices.
Adding Images in a WYSIWYG

1. Click on the “Images” icon in the WYSIWYG menu.
2. Choose a file from the file manager.
3. Double click on the name of the file.
4. Images will then appear in the WYSIWYG body content.
5. If needed you can resize the image within the WYSIWYG. If images should be cropped that will need to be done outside of Drupal.
6. If an image is uploaded, an "Alternative Text" field will appear and is a required field. Add a description of the image to comply with 508 compliance best practices. This text will be used by screen readers, search engines, or when the image cannot be loaded. Be descriptive but not too long and wordy.
Adding Content.. to specific content types

Blog

1. To create a blog article or news item, navigate via the Manage menu to Content, then select “Add Content” and then click “Blog”

2. Create a title for the page in the Title field (this field is required)

3. For every content type, there is a default image. If you would like to change this, use the Image field to upload your own. This will automatically open your personal media library. Alternative text will be required.

4. Once uploaded, you may drag the crosshair icon over the image to identify the center for default cropping.

5. You will need to provide body text and various elements via the Body field using the WYSIWYG, or the page will render blank. Here are your options:
   a. Text (using ‘Format’ field to create headers, etc)
b. Bulleted Text

c. Quote

d. Image (subtitle optional)

e. Video

f. Table

6. Then, you will need to select a Blog Type:

a. Blog Post

b. In The News

c. Press Release

7. If the blog content is in a language other than English, select the appropriate language from the Language field. Note that once a language is identified, this item will only show on that language listing page, and not on generic listing pages.

8. Under the URL and Path Settings tab you have the option to create a vanity or custom URL. Simply uncheck the box and include a forward slash before the alias to change (ie: /about)

9. The Publication Date is automatically set under the Authoring Information tab. You may change the designated author, date and time here by using the appropriate fields.

10. Check the “Published” checkbox if you would like the Blog Post to be published on the site

11. Click “Save” to save your content (or click save if you want to wait to publish the content later)

12. Click “Cancel” to leave this page and delete all content accordingly

Career

1. To add a Career, navigate to the Content tab and select Career
2. Enter Title into the Title Field (this field is required)
3. In the Hero section, create a subtitle and brief description of the job
4. Create a more detailed description of the job posting
5. Add who the role reports to in the “Reports To” field
6. Add item for each job responsibility in the “Major Duties and Responsibilities” field
7. Add items, as needed to the “Experience, Knowledge, Skills and Abilities” field
8. Add any necessary Physical Demands and description of the Working Conditions
9. Add Category by typing and selecting from the list of available career categories.
10. Add one file, as needed, as an attachment to the post

Committee Chairperson

1. To add a Committee Chairperson, navigate to the Content tab and select “Committee Chairperson”
2. Fill in the chairperson’s Name (required), Subtitle (required), Phone number, and Email (required)
3. Select “Save”

Committee

1. To add a committee, navigate to the Content tab and select “Committee”
2. Enter the new committee title
3. In the Hero section, add subtitle and body copy as a brief description of the committee’s purpose
4. In the Body section, under “Mission” add copy about the mission of the committee
5. Under “Our Strategic Goals” add committee goals (as needed). As you type, you will be given a selection of goals to choose from. Continue to add goals by using the
“Add another item” button. These can be reordered by dragging using the arrows to the left of the goal entry.

6. In the “Get Involved and Join Today” section, you will only need to add the WebAuthor ID below the form. This will indicate to whom form submissions should go.

7. To add Related Topics, related Blog posts, and relevant resources, begin typing and you will be given a selection of existing topics, blog posts or resources to select.

8. Select “Save”

Council Member

1. To add a Council Member, you will need to navigate to “Content,” “Add content;” then select “Council Member”
2. You will then need to add the person’s full name as the Title
3. Disregard the committee field (this is for the strategic plan committee component)
4. You will then need to upload a Headshot for this person. This is a required field, so you will need a placeholder image in the event you do not have an image for them
5. In the Attributes tab, you will need to fill out their professional title
6. You can select the Person Type from the drop down:
   a. None
   b. Board of Directors
   c. Executive Leadership
d. Experts

e. Officers

f. Senior Fellows

7. This section will also include the ability to capture this individual’s Education, Honors & Awards, Email Address, LinkedIn and Twitter information

8. In the Relations tab, you will include content that will need to be typed in the field and then selected once it appears for the following fields:

   a. Capabilities
   b. Focus Areas
   c. Region
   d. Key Projects
   e. Publications & Presentation

9. Then you can click “Save”

**Event**

1. To create an Events Page, navigate to Content then select “Add Content” and then click “Events”
2. Create a title for the page in the Title field (this field is required)
3. For every content type, there is a default image. If you would like to change this, use the Image field to upload your own. This will automatically open your personal media library. Alternative text will be required.
4. Once uploaded, you may drag the crosshair icon over the image to identify the center for default cropping.
5. Next, you’ll need to enter location details for the Event to populate the “Address” section on the frontend experience. Fill in:
   a. Location Name
   b. Street Address
   c. City
   d. State
   e. Zip code

6. Then, paste the entire address into the Geocode address field to populate the Map section on the frontend experience. The Latitude and Longitude will automatically populate based on the address you input.
7. You will then need to provide Date details. Start Date and time are required, and may be selected by using the date-picker or by manually entering in the following formats: 01/01/2018 (January 1, 2018) and 05:00:00 PM (5PM)

8. Related content and taxonomy details come next. You will first need to select an event type using the Type dropdown. At launch*, options are:
   a. Committee Meeting
   b. Community Event
   c. Council Committee Meeting
   d. Council Meeting
   e. TRIM Public Meeting

*This taxonomy may be updated to include additional event types, and this dropdown selection will automatically update to reflect those changes. See Taxonomy Updates portion of this guide for details.

9. It is not required that an Event have a topic(s), but it is recommended for an improved search experience. For internal, council and committee meetings, be sure to use “CSC Broward Operational”
10. If the Event content is in a language other than English, select the appropriate language from the Language field. Note that once a language is identified, this item will **only show on that language listing page, and not on generic listing pages.**

11. You have the option to attach an unlimited number of resources to an event. Taoti’s recommendation is to always link meeting minutes, presentations, and other materials that pertain to any given Event to the event itself. **Note that a resource will have to be created first** – only afterward, will it be searchable here.

12. If you would like to include a Call-to-Action, use the Button section to do so. To take the user to an external path, provide a URL including http://. For internal links, simply begin typing the page name or node path. Recommend using action language for the button text, like “Learn More” or “Register”.

13. You may provide additional context for an event by utilizing the Body field WYSIWYG element. Recommend using this section for agendas, and attaching the minutes as a resource. This will make the pages more likely to be found by search engines and users looking for specific event details. Here are your options:
   a. Text (using ‘Format’ field to create headers, etc)
   b. Bulleted Text
   c. Quote
   d. Image (caption optional, alt text required)
   e. Video
   f. Table

14. Under the URL and Path Settings tab you have the option to create a vanity or custom URL. Simply uncheck the box and include a forward slash before the alias to change (ie: event/September-TRIM)

15. The Publication Date is automatically set under the Authoring Information tab. You may change the designated author, date and time here by using the appropriate fields.
16. Check the “Published” checkbox if you would like the Event to be published on the site
17. Click “Save” to save your content (or click save if you want to wait to publish the content later)
18. Click “Cancel” to leave this page and delete all content accordingly

**Goal**

1. To add a Goal, navigate to the Content tab and select “Goal”
2. Enter the new goal title
3. In the Hero section, add subtitle and body copy as a brief description of the goal
4. In the body section, add more detailed copy about the goal
5. To create sections on the page, fill in the heading and description of the topic
6. To include a button as part of the section, start typing the title of an internal piece of content or type an external URL
7. Under “Link Text” type in the text that will appear on the button
8. You can also create additional section components as needed

9. Select “Add Section” for additional sections and reorder by dragging the arrows to the left of the section
10. Select “Save”
Homepage

1. When logged in as an Administrator, a small box will appear to the right hand side of the screen. Select “Edit” from this menu, when on the homepage.

2. You can update the language in the hero section by updating the “Label” field. Note that if you require unique styling, it will need to be done using HTML within the field itself. Ie: “Our Focus Is <u>Our Children</u>”

3. Hero body block copy may also be updated here, using the HERO > “Body” field

4. To add items to the Featured Content Section, navigate to the CURATED CONTENT block and search for a node by using the auto-complete form field. The Featured Content* item will populate the largest featured item, and the four fields that follow will populate the smaller featured item sections on the homepage. Note that the images pulled for each of these items are determined at the node-level. See Blog for an example of selecting a featured image for an individual node.

5. To update the links at the bottom of the page (sans imagery), navigate to the CONTENT block and use the same method to select which resources, etc. should be displayed.
Landing Page

1. To add a Landing Page, navigate to Content then select “Add Content” and then click “Landing page”
2. Create the new Landing Page title
3. In the Hero section, add subtitle and body copy as a brief description of the purpose of the page
4. You also have the option to include additional items in the Hero section such as a button, Purple Card, Curated Content, or Image Card

5. In the body section, add more detailed copy about the purpose of the page
6. To include page navigation, start typing the title of an internal piece of content or type an external URL
7. Under “Link Text” type in the text that will appear on the button
8. Select “Add Section” for additional sections and reorder by dragging the arrows to the left of the section
9. Select “Save”

Listing Page

1. To add a Listing Page, navigate to Content then select “Add Content” and then click “Listing page”
2. Create the new Listing Page label
3. In the Hero section, add subtitle and body copy as a brief description of the listing
4. Under results, add in the Title and Body description of the listing
5. To have the listing link out, add URL by typing the title of an internal piece of content or type an external URL
6. Under “Link Text” type in the text that will appear on the link
7. Select the appropriate listing category from the “View” dropdown menu
8. Select the “Display ID” to indicates the how the listing will be displayed
9. Add Curated Resources to the listing by typing and selecting from the content list
10. Select “Save”

**Program**

1. To create a Program, navigate to Content then select “Add Content” and then click “Program”
2. Add title of the program brief summary of the program
3. In the Body section, write a more detailed description of the program
4. Add link, as needed
5. Add contact phone number, as needed
6. To add Program Type, begin typing and select from program type options
7. Select “Save”

**Resource**

1. Every Resource should have an accompanying Resource Page. To add, navigate to Content then select “Add Content” and then click “Resource” or navigate to
   [http://test-childrens-services-council.pantheonsite.io/node/add/resource](http://test-childrens-services-council.pantheonsite.io/node/add/resource)
2. Create a title for the Resource Page in the Title field (this field is required)
3. For every content type, there is a default image. If you would like to change this, use the Image field to upload your own. This will automatically open your personal media library. Alternative text will be required.

4. Once uploaded, you may drag the crosshair icon over the image to identify the center for default cropping.

5. Next, you’ll need to enter Related content and taxonomy details. You will first need to select a resource type using the Type dropdown. Options include:

- Annual Performance Report
- Council Committee Meeting Agenda
- Council Committee Meeting Minutes
- Funding Resources
- Annual Report
- Strategic Plan
- CAFR
- Committee Meeting Agenda
- Committee Meeting Minutes
- Council Meeting Agenda
- Council Meeting Minutes
- County-Wide Ordinances
- Family Resource Guide
- Funded Program Directory
- Press Releases
- Proposed Budgets
- Service Delivery Guides
- TRIM
- Program Materials

*This taxonomy may be updated to include additional resource types, and this dropdown selection will automatically update to reflect those changes. See Taxonomy Updates portion of this guide for details.*

6. Next, select an appropriate topic from the dropdown field. For internal, council and committee meeting materials, be sure to use “CSC Broward Operational”

7. If the Resource content is in a language other than English, select the appropriate language from the Language field. Note that once a language is identified, this item will only show on that language listing page, and not on generic listing pages.
8. The **Year field is only required for items to appear on the About page.** Examples of appropriate content include: Annual reports, budgets, and performance reports. For items not intended to find a place on the About page, leave this field blank.

9. You may provide additional context for a Resource by utilizing the Body field WYSIWYG element. Recommend using this section to include as much content within a resource as possible. This will make the pages more likely to be found by search engines and users looking for specific information. Here are your options:
   - Text (using ‘Format’ field to create headers, etc)
   - Bulleted Text
   - Quote
   - Image (caption optional, alt text required)
   - Video
   - Table

10. Under the URL and Path Settings tab you have the option to create a vanity or custom URL. Simply uncheck the box and include a forward slash before the alias to change (ie: resource/September-TRIM-Minutes)

11. The Publication Date is automatically set under the Authoring Information tab. You may change the designated author, date and time here by using the appropriate fields.

12. Check the “Published” checkbox if you would like the Event to be published on the site

13. Click “Save” to save your content (or click save if you want to wait to publish the content later)

14. Click “Cancel” to leave this page and delete all content accordingly
Staff

1. To add staff, navigate to the Content tab and select “Staff”
2. Enter Name (required), Title, Phone, and Email fields for the staff member you are adding
3. Select Staff Type (required) from the drop down menu so that the staff member’s information will appear in the correct section
4. Select “Save”
10. To add a Goal, navigate to the Content tab and select “Goal”

![Content Tab Image]

Success Story

1. Navigate to the Content tab and select “Quote”
2. Enter in a Title for the Quote. Feel free to make the title whatever you would like but please associate it with the specific person who said it or the page it’s associated with, so it is easily searchable. You will be searching for this Node by what’s in the Title field, so ensure it is appropriate for what it may need to be searched by.
3. Then begin to type the name of the person who said the quote in the “Person” field and then it will pull in their information. If they are not appearing in the system, please see the Person Content Type instructions to create the Person needed for this reference.
4. Lastly, enter in the quote in the Quote field
5. Select “Save”
Taxonomy Overview

Taxonomy vocabularies are used to make content sortable and to relate content (even among different content types) thematically. The CSC Broward website has thirteen main categories of taxonomies:

- Blog Type
- Career Category
- Committee Type
- Event Type
- Fiscal Year
- Group
- Language
- Program Type
- Resource Type
- Salary Range
- Staff
- Strategic Plan Goals
- Topic

Even if the taxonomies are not required fields when creating a node, be sure to use them where appropriate.

Taxonomy fields are set as auto-complete text fields but can also be in a dropdown or checkbox format for the auto-complete text fields. Be sure to wait for the appropriate term to appear, or you may end up creating duplicates in the taxonomy vocabularies. If selecting multiple tags, click on the “Add Another Item” button.

The list order in the field is the same as the list order on the taxonomy vocabulary’s page.
Adding and Editing Taxonomies

To add, remove, edit or reorder terms in a particular vocabulary:

1. In the admin toolbar, go to Structure > Taxonomy

   a) To add a term to the vocabulary, click the “Add Vocabulary” button at the top of the page

   b) To remove a term from the vocabulary, follow the arrow to the list of terms and then click the ”Delete” button

   c) To edit a term in the vocabulary, click the “Edit” button next to that item, edit the term as needed, and then click the “Save” button

   d) To reorder the terms in the vocabulary, select “Taxonomy” then click the four-way arrow icon and drag and drop the terms in the list
2. Always be sure to click “Save” on the term and on the vocabulary pages when you are done making changes
Updating Menus

CSC Broward’s site has three menus that are displayed to front end users. The front-end user menus for the site are:

- **Main Navigation** – This controls the items in the main menu: Families, Providers, Community Builders
- **Secondary Menu** – This controls: About, Blog, Events, Meetings, Resources, Training, Careers, Contact, and Search
- **Footer** – This controls the items within the footer: Learn About Us, Attend an Event, Read the Strategic Plan

You can control the order of the menu links by dragging and dropping the crosses to the left of the text. Make sure to save your work at the bottom of the page after you make any changes.

**Main Navigation**

To add a link to the menu:

1. In the admin toolbar, go to **Structure > Menu > Main Navigation > Add Link**
2. Click the “Add Link” button at top of page
3. Enter the name of the menu item into the “Menu Link Title” field
4. Add the path for the menu link into the “Link” filed
   • If an internal Drupal URL, add the path such as “node/1234” or “about”
   • If an external URL, add the entire URL, including the http://
5. Select “Main Navigation” from the “Parent Link” dropdown
6. Click “Save”

To reorganize the navigation:

1. Grab the cross-arrow graphic to the far left to drag it up, down or to the right or left for the desired positioning
   • If it’s indented once, then that item will appear on the secondary navigation
   • If it’s indented twice, then that item will appear in the tertiary navigation

---

**Footer Menu**

To add a link to the menu:

1. In the admin toolbar, go to **Structure > Menu > Footer > Add Link**
2. Click the “Add Link” button at top of page
3. Enter the name of the menu item into the “Menu Link Title” field
4. Add the path for the menu link into the “Link” filed
   • If an internal Drupal URL, add the path such as “node/1234” or “about
   • If an external URL, add the entire URL, including the http://
5. Select “Footer” from the “Parent Link” dropdown
6. Click “Save”
Adding Users

1. In the admin toolbar, go to **People > Add User**

2. Enter email address, username, password and select appropriate role

3. You can check off “Notify User of New Account”, but often the email gets stuck in the spam folder, so it may be just as easy to directly email the user with their username and password

4. Click “Create New Account”
Accessibility Best Practices

- Maintain structured content by using descriptive text in appropriate heading tags (h1, h2, h3, etc.)
- h1 is typically the node title. This should be the only h1 on the page.
- Other headings should be used to outline the page. Think of h2s as section headers and h3s as components of that section.
- Don’t assign headings based on how they look, as this is bad for accessibility as well as SEO.
- Heading styles can be accessed in the Format dropdown of the WYSIWYG tool bar. If the Format dropdown does not appear, click the show/hide toolbars button at the far right of the top row of tools.

- Always use alt text and title text for images
- Alternative text is used by screen readers, search engines, and when the image cannot be loaded.
- Title text is used in the tool tip when a user hovers their mouse over the image. Adding title text makes it easier to understand the context of an image and improves usability.
- You will have the opportunity to add alt text and title text when uploading files and images to Drupal. When uploading an image through Add Media using the instructions above, adding alt text and title text will be a part of that process.
- Do not include "Read more" or generic links in designs or text — make them descriptive. A common way of navigating through the content of a website with assistive technology is by skimming the list of links by tabbing through them. However, if the text of all the links in the main content of the page is "Click here" or "more", this method of scanning content becomes useless.
• Provide alternatives for multimedia presentations, such as closed captioning or transcripts for videos. Closed captioning can be done directly through YouTube. Transcripts can be uploaded to a WYSIWYG using the instructions above.
• For any information that is conveyed with color, also convey that information without color. For example, if you change the color of text for emphasis, add an underline or non-color treatment as well.
• For files uploaded into WYSIWYGs, provide a link to program needed to view it. Include row and column headers on tables.
• Remember that compliance guidelines do change. Evaluate the site frequently to assess newly added content and to compare the site against the newest guidelines.

**If your changes aren’t appearing right away...**

If your changes aren’t appearing right away, always try to flush the cache before thinking there’s an issue. To do so:

• Hover over the Drupal 8 icon in admin menu
• Click on “Flush all caches”, then wait a few minutes while the page refreshes